Some candidates having issues advancing conversations

Incident Report for Advantage

Resolved

This incident has been resolved.
Posted May 14, 2026 - 14:44 MST

Identified

We are investigating an issue with conversations not advancing after accepting Terms and Conditions
Posted May 14, 2026 - 11:31 MST
This incident affected: Conversations (Site Widget).